The project is either not a TFS project or has not been setup to use TeamReview.

Jul 31, 2008 at 11:30 AM
I use VS.NET 2008 pointing to a TFS 2005 server. I have installed the 2008 version of Add-in and imported the 2005 version of work item. I see Code Review Response as an work item type in team explorer. Also in the c# code, on right click, I see Code Review menu in the VS.NET IDE. However, when I select "New Code Review Response", I get the following error

The project you are working on is either not a TFS project or has not been setup to use TeamReview.

To setup a TFS project for TeamReview usage please follow the directions on the TeamReview CodePlex site at

Thank You,

TeamReview contributors

Please help.


Jul 31, 2008 at 6:04 PM
Are you using the latest release (1.0.5)? 

That message will display for a few reasons:

  1. The code you are working on is not bound to TFS source control
  2. Your Visual Studio is in "Offline" mode and can't do the connection to determine the TFS workspace mappings
  3. The Code Review Response is not a work item type in the Team Project (you've already validated this not to be the issue appropriately)

TeamReview detects the Team Project being used by determining the TFS Workspace that the code is within on your machine, and then getting the Project mapped to that Workspace + Solution file path combination. If all of the things above prove to be true and you still get the message you are receiving above then their may be a bug.

The code determining the points above is done each time the active Visual Studio solution changes in the DependencyLocater class here in the SolutionEvents_Opened event handler which then calls TFSService.SetProject method  here

Then later when you try to use the TeamReview menu the code that determines if that pop-up should be displayed instead of the requested action can be seen here and then calling ITFSService.IsProject here

My team at my day job has the same setup that you have (VS 2008 & TFS 2005) and everything seems to be working properly, so this may be a tricky defect to isolate.

Please, let me know what you find.
Aug 1, 2008 at 7:46 AM

Thanks for your immediate and accurate response. When I brought my solution under source control online, the issue was resolved.

This is the best end-to-end solution using TFS and VS.NET customization features we have see to date. Thanks for your good work.

Jul 13, 2009 at 4:17 PM

Hi all,

I'm testing Team Review on the virtual Team Foundation Server machine you can download from Microsoft.

The original machine had a complete VS2008 and a VS 2005 Team Explorer installed. To simulate the situation in our company, I installed VS 2005 C# and C++.

I imported the template. Adding a "code review response" via Team->Add Workitem works fine in both Visual Studios. In VS 2008 the addin works fine too, but in VS 2005 the addin always reports the same error as Balaji reported above.

I can check in and out, all the bindings to Team Foundation Server are fine.

I have no idea anymore :-)

Any help would be great!



Aug 4, 2009 at 10:08 PM

The fix for this issue was published in release 1.1.1 today -