Configuration and set up issues

May 5, 2009 at 1:54 AM

I've installed team review on my client machine and uploaded Code Review Response.xml as Work item in our TFS project.
I can use the "Team->Add Work Item" menu option and choose "Code Review Respose". So it looks like TFS project is configured correctly.

There seems to be some missing piece in client TeamReview Addin. When I install the client components, it correctly create a VS Addins and I can right click in VS to see Team review menu. However clicking on the menu fails with a dialog box "Project Setup instructions". Followed the exact steps on the thread = 25834 as mentioned in the instructions and still no luck

You can see below in yellow, Addin present at My Documents\Visual Studio 2008\Addins points to the correct location of the team review binaries on my machine.


<?xml version="1.0" encoding="UTF-16" standalone="no"?>

<Extensibility xmlns="">


    <Name>Microsoft Visual Studio</Name>





    <Description>new business value from code review</Description>

    <Assembly>D:\Program Files\TeamReview\TeamReview (2008)\TeamReview.VSNetAddIn.DLL</Assembly>





    <AboutBoxDetails>For TeamReview support visit</AboutBoxDetails>



Any quick pointers will be appreciated. We are evaluating different code review tools for our team. 

May 5, 2009 at 2:12 AM
As you receive the "Project Setup Instructions" the addin is functioning correctly with VS2008.
Is the solution/project, you have open, under source control within the TFS project?
Double check the witimport worked for the teamproject.
May 5, 2009 at 5:44 PM
Yep project is under source control in TFS. Files can be checkout, view the pending changes etc.
May 20, 2009 at 2:04 AM

In our Demo TFS project, we just put few files for evaluating code review tool.

 However it looks like you need to have a solutions file binded to TFS for it work. After adding solution, we are able to proceed forward

May 20, 2009 at 2:41 AM

Yep - you found the missing piece. For various reasons TeamReview relys on an open Solution being bound to TFS source control in order to determine the team project in use and that the Code Review Response work item type is in that team project.

Thanks for evaluating TeamReview and working through the issue!


May 22, 2009 at 1:37 PM


I have the exact same problem: creating work item starting from the "Team->Add Work Item" works, but using the addin with the context menu gives the project setup instructions. The solution is under source control, underneath the correct TFS project where I imported the WIT for. When I go to the the source control settings for the solution, it is bound to the the TFS server. Is there another reason why the adding can complain that my project is not configured for TeamReview?


Thx for your advise


May 22, 2009 at 1:48 PM

Did some further investigation and found the cause. Apparently, you cannot use the addin for a solution that is newly created without having been closed. So if you create a new solution, put it under source control, check it in and try to use the review context menu, it will not work. If you close the solution and open it again, the review tool will work as expected. Just encountered this during some "tests" with the tool... in real life scenario's, newly created solutions will seldomly be reviewed without having been closed and opened one time :-)

Kind regards, thx for the utility,