TeamReview incompatable with with VS2008 PowerCommands?

Oct 29, 2009 at 9:37 AM

Hello,

With the VS2008 PowerCommands addin installed, the following appears in the TeamReview log file on VS startup, and the TeamReview work items fail to work from the context menu in a code window:

29/10/2009 09:30:54 System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.PowerCommands.Commands.ShowAllFilesCommand.CanExecute(OleMenuCommand command)
   at Microsoft.PowerCommands.Commands.DynamicCommand.OnBeforeQueryStatus(Object sender, EventArgs e)
   at Microsoft.VisualStudio.Shell.OleMenuCommand.get_OleStatus()
   at Microsoft.VisualStudio.Shell.OleMenuCommandService.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)
   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)
   at Microsoft.VisualStudio.CommandBars._CommandBars.get_Item(Object Index)
   at TeamReview.VSNetAddIn.Connect.BuildMenu()
   at TeamReview.VSNetAddIn.Connect.OnConnection(Object application, ext_ConnectMode connectMode, Object addInInst, Array& custom)

 

Nb: when selecting the TeamReview actions on the context menu, a modal dialog is displayed containing the following text:

"TeamReview is the most complete solution for Team System Code Reviews: a specific work item type and a Visual Studio add-in for a completely in IDE code review experience.

To use TeamReview Visual Studio must be online, a Visual Studio Solution must be open and within a Team System workspace mapping. Additionally Team Projects that that will store work items must have the Code Review Response work item type.

To setup a Team System project for TeamReview usage please use the following directions from the TeamReview codeplex site.

Thank You,
TeamReview contributors"

 

Anyone else see this, or know of a workaround?

Many thanks, Harvey

Mar 8, 2010 at 3:34 PM

Identical problem here.  Others with PowerCommands installed are also toast.